Visual Productions forum

Products => CueluxPro => Topic started by: bart sliggers on March 20, 2014, 05:02:47 PM

Title: 30 issues with cueluxpro
Post by: bart sliggers on March 20, 2014, 05:02:47 PM

General cueluxpro issues: (XP 32bit.)

- One of my curecore pulses flashes red/white, everything else seems to function all right. Any Idea what could be the matter ?

- Sometimes I don't get visualtouch to work with cueluxpro. Sometimes a local client does not work, restart fixes this. Sometimes external client "sees" the cuecores, cuelux "sees" the cuecores, but client does not see cuelux. (firewall disabled)

- In matrix ; Feature request : overview, Make a possibility to visualise mapped pixels only. Sometimes the mapped pixels have a particular shape or sometimes pixels a intentionally left unmapped. It would be nice to see this shape in the overview.

- In matrix, rotating of the mask-gobo happens √°fter scaling. If the layer has a non-square aspect ratio, this look ugly. I would like to see : Rotating first, scale to layer second.

- With patterns : There is only one way of mixing layers, I would like to see masking and non-linear mixing.

- Drag and drop of groups, fixtures and palettes would make life so much easier.

- With patterns : I would like to see better anti-aliasing of zoom- and rotation- and iris effects.

- With patterns : Regardless of the color of the pattern effect, if the zoom fader is put to 100% the pattern becomes black.

- Selection action does not work, or at least not how I expect it to work. How does this action differ from the group action.

- I can't get an axis input action to control the pan/tilt. (both visualtouch and OSC) How do I do this?

- I can't get an fader input action to control the RGB values. (Colorpicker does work) How do I do this?

- I would like to have Ctrl+a = select all in a list. To delete or to copy/paste

- I would like to have a "virtual" strobe / shutter / dimmer attributes for generic RGB fixtures.

- Identifiers: a HORRIBLE concept. I want modern software to keep track of my patterns/palettes/bundles/groups/buttons/faders etc. What happens if i decide to delete a buttonbank ? Is the link dynamic ??

- There *HAS* to be a protection against acidentally deleting an action list. If you press the left- instead of the right-remove button, hours of hard work down the drain !!!

- When editing a palette, removing a fixture out of a list of multiple fixtures seems to corrupt the list.

- In patterns: It would be nice if 25-50-75% would correspond with 90,180,270 degrees. Right now it results in ulgy alias tears.

- With patterns : Fill,gradient radial,twinkel,sinus,spectrum,zigzag,checker, I get ugly black pixels in the corners at 13%, 38%, 63% rotaion. Other patterns have no problem with this.

- With patterns : Custom faders that are not applicable should be grayed out, as it is the case with all other attributes.

- With patterns : gobos with a number? a HORRIBLE concept. I want modern software to keep track of labels.

- With patterns fire en confetti : dimmer fader and colormix do not work! Fire is too low, and does not scale with large layers!

- With patterns Effect "Scan" is too bright or has too little contrast. Speed fader seems to act strange above 50%. Shouldn't this be mapped to the rotation fader ?

- With patterns radar has no working custom faders.

- With patterns cardio does not seem to work at all.

- With patterns Circular fill does not seem to work well, especially in combination with rotation.

- With OSC, a button action gives two triggers, one for up one for down. Not good when you want to step through a cuelist. There should also be a flank selection for osc buttons.

- With OSC, large page labels are not accepted. Page labels 1,2,3,A,B are accepted. "Intelligent lighting" is not.

- When editing cuelists, you can only delete attributes. There is no way to add attributes.

- When editing a playback button/fader, there is no clear indication of what fader/button you are "in". Please set the name/number of the bank/buton/fader in the magenta left header!

- When editing a playback button/fader the "arrow buttons" are not consistent. Right here they mean "step forward" and "step backward". In the action edit they mean jump to next and previous action.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on March 21, 2014, 11:08:20 AM
- When controlling a palette with a colorpicker action, the rgb faders in the programmer are not properly updated. The first pick works, later picks don't.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on March 22, 2014, 11:49:47 AM
Hi Bart,

Thanks for the detailed feedback. Next week we start a new development cycle for cpro. We will try to address the majority of the issues in the next release. We will report back the progress.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on March 27, 2014, 04:56:19 PM
CueluxPro v1.3.65 is now available from our FTP. It's an intermediate release; the next release will follow shortly.

- One of my curecore pulses flashes red/white, everything else seems to function all right. Any Idea what could be the matter ?
Perhaps you have an early model of the CueCore that was supplied with two LEDs; nowadays the CueCore is only fitted with the white LED. This will not affect the operation of the CueCore.

- Drag and drop of groups, fixtures and palettes would make life so much easier.
We optimised the GUI for touch screen control therefor we generally do not implement any drag/drop features.

- Selection action does not work, or at least not how I expect it to work. How does this action differ from the group action.
The 'Set' and 'Toggle' function in the selection task were not yet implemented. We have added a parameter for entering the fixture number; it is now working. The 'All', 'Next' & 'Previous' functions were already working.

- There *HAS* to be a protection against acidentally deleting an action list. If you press the left- instead of the right-remove button, hours of hard work down the drain !!!
This is why there is a undo button. For the action list the undo was not working correctly. This is now fixed.

- When editing a playback button/fader, there is no clear indication of what fader/button you are "in". Please set the name/number of the bank/buton/fader in the magenta left header!
The magenta header now shows the bank.playback number.

I will address the other issues with the next release.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on March 31, 2014, 01:55:10 PM
Thank you, I'll give it a go. :)
Title: Re: 30 issues with cueluxpro
Post by: Rayco on April 02, 2014, 01:34:50 PM
Quote from: -bart- on March 20, 2014, 05:02:47 PM
- Drag and drop of groups, fixtures and palettes would make life so much easier.
We optimised the GUI for touch screen control therefor we generally do not implement any drag/drop features.


It could easily be made drag-and-drop in a 'set-up' option.

Moving fixtures around is a real PAIN !!!
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 02, 2014, 02:44:38 PM
I can not install 10366 due to problems with msvcr110.dll (xp 32bit)  ???


10365:

-Loading the file you are currently working in,(i.e. loading a file for the second time) results in a freeze or crash.

-When a file is being loaded, impatiently pressing buttons can lead to a crash or freeze

-Matrix / layout is consuming too much processing resources, (I may have 440+ fixtures, but drawing some GUI stuff does not justify gigaflops processor load causing the output to stutter)

-The matrix layout of the fixtures (position and rotation) is often corrupted for no obvious reason. It seems to be cosmetically, GUI only. Rendering is to dmx is OK. Importing layout fixes it. But it gives me a heart-attack to see a 400+ fixtures layout scrambled. (maybe custom fixture related? or something to do with layer fixtures being always ontop)

-Knockout group does not work.

-Knockout playback only deletes the cue and its link, not other playback data. So a playback that seems to be empty still contains playback settings and properties. Bundle-settings being the most annoying.

-Auto-patch can be a p.i.t.a, Now, newly added fixtures end up in 'holes'in universes i don't want. So I have to find them first and re-patch them. Please only auto-patch fixture into the "visible" universes.

*** Adding and pasting actions in a actionlist; Please insert new actions after the selected action! Not to the bottom of the list, it is tedious.

-Actions, page breaks. It would be nice if they are labeled [End of Page n.] by default.

-Adding tasks to a dummy or a page-break, shouldn't that be made impossible ? Or make the task-type editable, so you can (temporally) change an action into a dummy so it becomes invisible. Or easily change a horizontal fader in vertical one.

-Label-names can not be copy-pasted. You can't insert with the cursor. Littlebit archaic for an 2014 app.

-FX generator (position/color/dimmer) : Negative size does not work. (maybe not even necessary / needed)

-Knocking out position/color/dimmer FX does not work without entering the fx-menu-itself.

-The subs of a fixture like the amdj sweeper beam led are not controllable afaik (whithout mapping it in a matrix).

-When moving from matrix-overview to status sometimes fixture and palette are invisible, while their buttons are lit. Pressing status again fixes this.

-Negative values, such as gobo rotation, are not properly recorded in palettes / Negative values can not be set in the palette editor. Please add numerical input to the palette/cuelist attribute editor.

-Attribute values that are "blank"/"transparent" recorded in a palette (because the attribute belongs to another fixture) can not be changed in the pallete-editor.
The other way around, Attribute values can not be made "blank"/"transparent" in the palette-editor.

-Palette-labels are nameless by default. Why? All other things have default labels.

-Could there be an opt-in/out to be prompted to enter a name for each an every new cue/action/palette/label, etc you create? Right now I keep recording, renaming, recording renaming, which feels quiet tedious.

-If the processor load is high (by other processes than CLP) cuecores seem to reset themselves, causing a blackout of 2 seconds.

-After loading a file, showtec phantoms are magically transformed into expressions 5000 (which come next in the list). Replacing fixture had no effect. After adding the phantoms to the list instead, planning to remove the sick fixtures, the phantoms are magically cured.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 02, 2014, 10:22:02 PM
-Undo knockout playback does not work. Even worse, if you have two playbacks assigned to one cuelist, the cue is killed if you knockout one of the playbacks.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 03, 2014, 10:51:28 PM
-In the cuelist overview you can't select multiple cuelists. (to copy paste them for instance)

-If you move cuelists up/down in the cuelist- overview the link to the playbacks remains in tact. If you cut/paste the the link to the playback  is lost. (As with actions, pasted and added cuelists end-up at the end of the list. Please insert them after selected cuelist.)
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 06, 2014, 09:50:02 AM
-Action editor : Tasks can not be copy pasted.

-Action editor: It would be nice if the default identifier would be like the last one used .
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 12, 2014, 07:18:37 AM
I still can not install 10368 due to problems with msvcr110.dll

Both XP and windows 7.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 17, 2014, 09:45:18 PM
With OSC action tasks type: palette feature: colour RGB function: Set

There is no way to set parameter1; dialogbox is missing.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 19, 2014, 10:37:16 PM
With OSC action tasks type: palette feature: intensity function: Set

There is no way to set parameter1; dialogbox is missing.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 24, 2014, 09:12:42 PM
The symbol used in the shapegenerator for the figure-eight has an error:

If the arrow at the topside points to the right ->,

Then the arrow at the downside of the figure-eight should also point to the right . ->

On a serious note: I would like a laying figure eight too.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on May 26, 2014, 01:12:41 AM
 :)
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 26, 2014, 10:44:58 AM
When doubleclicking a playback-indicator you are transfered to the cuelist editor.

When you are already in the cuelist editor, doubleclicking other indicators will update the magenta cuelist-label on the left,

But it does NOT update the cuelist properties, such as bundle and faderstart.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 31, 2014, 02:15:58 PM
I do recall reading somewhere that movie-pattern was not yet implemented on the mac.

Please fix this soon, I need this.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on May 31, 2014, 02:19:19 PM
The arrow-buttons in the edit-pattern screen do not work.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on June 05, 2014, 02:09:04 PM
When doubleclicking a playback-indicator you are transfered to the cuelist editor.

When you are already in the cuelist editor, doubleclicking other indicators will update the magenta cuelist-label on the left,

But it does NOT update the cuelist properties, such as bundle and faderstart.

Related to this issue

I have some cues, not all it seems (bank no >1 ??):
Right from launching CLP, when I choose to edit a playback, without starting  anything first, it seems to be empty! (no bundle, no faderstart, no cues assigned) Starting the cue then suddenly fills in the info.

Also when I was changing the bundle of a playback, the bundle overview was inaccurate. It had forgotten bundles that are used for sure. Not sure what the exact conditions were.


Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on June 10, 2014, 08:51:57 PM
When you are in the cuelist editor, stepping though the banks will update speed, attak and fxrate faders.
However, cuelist-label, cuelist properties and the cuelist itself is not updated.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on July 02, 2014, 09:07:09 AM
hi Bart,

7 of your points are addressed in the new v1.3.69 release (http://www.visualproductions.nl/forum/index.php?topic=3372.0).

We'll continue working on the other points.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on July 02, 2014, 09:13:34 AM
-Action editor : Tasks can not be copy pasted.

It was already possible to copy/paste a task by selecting the complete row (all the cells). Selecting individual cells would just copy/paste that particular cell value.
Now in v1.3.69 you can also copy/paste a complete task just by selecting the first cell (action type).
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on July 03, 2014, 11:45:56 AM
-Cueluxpro instantly crashes on the mac when I use iris attribute (on a layer), both in the progammer and via a cue / palette.
On a pc this works fine.

-Zoom and  frost attributes don't work on pattern type Vortex.

Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on July 16, 2014, 10:46:34 AM
When using the up/down arrow buttons in the matrix layer overview to change the order of the layers, the selected layer does not move along with the moved layer. I think it should work like the up/down arrow buttons in the action-overview or action-editor.

When using the left/right buttons in the tasks-editor of the cue-list-task editor, I am transfered to one of the actions in the action-list.
Clicking 'back' does not transfer me back to the tasks-editor of the cue-list editor.

Copy-pasting cues in the cue-list editor does not copy the task-content.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on July 16, 2014, 10:58:38 AM
Using a non 24-bit .bmp crashes cueluxpro when that pattern is used.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on September 07, 2014, 03:38:13 PM
I keep on having issues with gobowheel 1 (at non-1 pattern pages) with patterns in palettes in playbacks.

For example: status icon indicates gobo 2-5 yet gobo 1-5 is rendered.
Seems to be related to the previous values.

I can not isolate the exact conditions, but it is very persistent, and highly annoying. (both win and mac)
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on September 10, 2014, 03:31:05 PM
hi Bart,

We've solved a couple more issues with release v1.3.71. Please see http://www.visualproductions.nl/forum/index.php?topic=3406.0

cheers,
Maarten
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on September 11, 2014, 12:13:44 PM
The matrix layout of the fixtures (position and rotation) is often corrupted for no obvious reason. It seems to be cosmetically, GUI only. Rendering is to dmx is OK. Importing layout fixes it. But it gives me a heart-attack to see a 400+ fixtures layout scrambled. (maybe custom fixture related? or something to do with layer fixtures being always ontop)

We dealt with this issue in v1.3.71. I think it is solved now, but I don't know if the fix works in every situation. We cannot reproduce it ourselves any more after this fix. Please let us know if it still occurs on your end.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on September 22, 2014, 10:19:28 AM
We dealt with this issue in v1.3.71. I think it is solved now, but I don't know if the fix works in every situation. We cannot reproduce it ourselves any more after this fix. Please let us know if it still occurs on your end.

seems to be fixed. I will test 1.3.71 a little longer before I try it live.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on September 22, 2014, 10:22:40 AM
Renaming playbacks doesn't work in most non-overview views.

Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on September 22, 2014, 10:42:17 AM
Still... when editing playbacks,
A playback seems to be empty if it has not been activated since start up.
Starting the playback make the cues suddenly appear.

Also still...

Bundles that have not been activated since start up, seem to be unused.
Using them, shows them as in use again.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on November 09, 2014, 10:40:23 PM
I probably mentioned this before:

If I cut paste cuelists in cuelist overview, their links to the playback becomes lost.

Pasting cuelists will insert them at the end of the page instead of inserting them after the selected cuelist.
Title: Re: 30 issues with cueluxpro
Post by: Maarten Engels on November 11, 2014, 10:14:50 AM
tx, we'll try to get this sorted with next release.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on November 14, 2014, 04:33:14 PM
Could you please clear the pixel buffer when selecting a new pattern.
 Right now, leftover-content of the previous pattern persist when switching between certain gobos.

Also, please reset the "internal" rotation index of the pattern when selecting a new pattern.
Not only the gobo rotation index but also the internal-effect-rotation index.
When I want 2 rotating patterns with a 90 degrees shift, cuelux seems to remember an incremental rotation,when switching between patterns, if that makes any sense.
Title: Re: 30 issues with cueluxpro
Post by: Boyd Nijsten on November 14, 2014, 10:31:32 PM
Copy-pasting tasks doesn't work either...
Beam tab in programmer doesn't turn red.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on December 01, 2014, 01:59:31 PM
The goborotation of gobo 3 gives glitch-like hickups in the matrix.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on December 16, 2014, 09:21:38 PM
Renaming pages in the matrix pattern area does not work.
Title: Re: 30 issues with cueluxpro
Post by: bart sliggers on February 02, 2016, 05:41:03 PM
The reason that this thread is no longer updated is NOT because all issues were resolved or a stable version has been released, in contrary.

If a company hosts a forum that is teeming with posts and threads with bug reports for all to see, which are not addressed timely and properly, then it does not hold its product nor its users in great esteem.