Visual Productions forum

Author Topic: 1.02b6 beta feedback  (Read 4558 times)

April 14, 2010, 02:04:54 AM
Read 4558 times

vnx

  • Member
  • *
  • Posts: 93
Hi,

Here are some things I found to be buggy (almost all MIDI related):

1. The Record-Button still cannot be controlled via MIDI. I used the following XML from the elation.xml:

Code: [Select]
<action>
  <trigger type="Midi" specifier="Change">Channel 0 - Message 9 - Index 62</trigger>
  <tasks>
    <task type="Special" feature="Record" function ="Set"/>
  </tasks>
</action>

2. The Fader-start-enabled cues still start running on startup of Cuelux, which I consider a major annoyance as I have explained in another thread (http://www.visualproductions.nl/forum/index.php?topic=988.0). Automatic cue-start/stop on the flash buttons is working great!

3. The new Playback Direct Button xx Active feedback triggers (see http://www.visualproductions.nl/forum/index.php?topic=977.0) do not appear to work. I use it like this:

Code: [Select]
<action label="SCG1 SHUT">
  <trigger type="Unsigned" specifier="Change">Playback Direct Button 09 Active</trigger>
  <tasks>
    <task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 36</argument>
    </task>
  </tasks>
</action>

4. When Cuelux starts up, it sends all kinds of funny Note on/off messages that make *some* of my controller LEDs light up. In fact I have some (for testing stripped down version of) MIDI feedback triggers in my mapping like this:

Code: [Select]
<actionlist enabled="true" label="Feedback Play Buttons" source="System">

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 01 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 1</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 02 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 9</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 03 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 17</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 04 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 25</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 05 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 33</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 06 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 41</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 07 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 49</argument>
</task>
</tasks>
</action>

<action>
<trigger type="Unsigned" specifier="Change">Playback Button 08 Active</trigger>
<tasks>
<task type="Midi" function ="Control">
<argument type="Midi Address">Channel 1 - Message 9 - Index 57</argument>
</task>
</tasks>
</action>
</actionlist>

The MIDI adresses correspond to a row of 8 buttons on my controller, that very nicely match the playback buttons of Cuelux. Here is the output of MIDI monitor showing what Cuelux sends to my controller on startup:

Code: [Select]
*** ZERO *** To Control Surface Note Off 2 1 0
*** ZERO *** To Control Surface Note On 2 9 127
*** ZERO *** To Control Surface Note Off 2 17 0
*** ZERO *** To Control Surface Note On 2 25 127
*** ZERO *** To Control Surface Note Off 2 33 0
*** ZERO *** To Control Surface Note On 2 41 127
*** ZERO *** To Control Surface Note Off 2 49 0
*** ZERO *** To Control Surface Note On 2 57 127
*** ZERO *** To Control Surface Note Off 2 1 0
*** ZERO *** To Control Surface Note On 2 9 127
*** ZERO *** To Control Surface Note Off 2 1 0
*** ZERO *** To Control Surface Note On 2 9 127
*** ZERO *** To Control Surface Note Off 2 1 0
*** ZERO *** To Control Surface Note On 2 9 127
*** ZERO *** To Control Surface Note Off 2 17 0
*** ZERO *** To Control Surface Note On 2 25 127
*** ZERO *** To Control Surface Note Off 2 17 0
*** ZERO *** To Control Surface Note On 2 25 127
*** ZERO *** To Control Surface Note Off 2 17 0
*** ZERO *** To Control Surface Note On 2 25 127

So as you can see, there are some buttons (9,25,41,57) that eventually light up, indicating that the feedback triggers got activated on startup for apparently no obvious reason. E.g. I do not even have cues programmed on Playback Button  04 of the first playback button bank but the trigger for address 25 got nevertheless activated. I hope I could make clear what the problem is, as this is not as easy to describe...

Best,

Ben
« Last Edit: April 14, 2010, 02:54:57 AM by vnx »
Cuelux 1.03b22 on MacBook Pro (MacOSX 10.6.5) / Thinkpad X41t (WinXP) using Livid Ohm64 Controller

April 17, 2010, 10:26:41 AM
Reply #1

KnowSlumber

  • Member
  • *
  • Posts: 145
At a gig now:

Couple of bugs.

Mapped slider to speed control. Speed changes on counter, but doesn't affect chase speed. Tap tempo works , manual speed change works.

Mapped chase to go buttons. When triggered through go buttons, chases go twice their normal speed.

On startup, all fixtures have colors at max (i.e. white). Didn't happen on previous versions, screws up my cues.

Also, everything vnx said.

But I do want to say, this is a way more stable verison. I didn't have a single crash all night. Slowed down on save, but that's it.

Awesome work so far Maarten, its come a long way since 0033. :D


Oh, one more thing. Would it be possible to get it so when one assigns a Group to a Playback Fader, the fader control the Dim of the fixtures in the group?

It would be pretty key to be able to control the brightness of groups individually via midi...
« Last Edit: April 17, 2010, 10:38:41 AM by KnowSlumber »

April 17, 2010, 10:33:09 AM
Reply #2

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
ok, give me one hour. will debug bpm control now.
white startup colour is already fixed.
Maarten Engels
Visual Productions BV

April 17, 2010, 10:35:36 AM
Reply #3

KnowSlumber

  • Member
  • *
  • Posts: 145
What are you doing coding on a saturday?  :'(
« Last Edit: April 17, 2010, 10:40:56 AM by KnowSlumber »

April 17, 2010, 11:23:28 AM
Reply #4

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
A nice and quiet, undisturbed programming session  ;)
Maarten Engels
Visual Productions BV

April 17, 2010, 12:20:01 PM
Reply #5

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
v1.02.7 is online. Did I make it before the 'encore' ?  ;)

/****************************************************************************************
 *   RELEASE 1.02 Build 7
 ****************************************************************************************/
Release Date  : 2010 April 17
New Features  :
- Novation Launchpad midimap
- MIDI feedback messages expanded
- Elation Midicon midimap improved
- Korg nanoPAD corrected
Solved Bugs   :
- Control Tempo via Midi did not work properly
- Incorrect default value (white) for ColourRGB parameter
- iPhone remote control had 10 playback button instead of 8
Limitations   :   
- Ubuntu: no MIDI devices



will continue to work on the other issues....
« Last Edit: April 17, 2010, 12:22:58 PM by Maarten Engels »
Maarten Engels
Visual Productions BV

April 17, 2010, 12:34:08 PM
Reply #6

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
1. The Record-Button still cannot be controlled via MIDI. I used the following XML from the elation.xml:

This does work over here. just to check: do you have info in the programmer when you try record? If the programmer is empty record doesn't do anything.
Maarten Engels
Visual Productions BV

April 17, 2010, 05:00:46 PM
Reply #7

vnx

  • Member
  • *
  • Posts: 93
Hi Maarten,

Yes, you are totally right, my fault!

Best,

Ben
Cuelux 1.03b22 on MacBook Pro (MacOSX 10.6.5) / Thinkpad X41t (WinXP) using Livid Ohm64 Controller

April 20, 2010, 08:15:24 AM
Reply #8

AxelF

  • Member
  • *
  • Posts: 152
Maarten,

did you also publish a new Emulation version ?

Regards

Axel

April 21, 2010, 09:24:21 AM
Reply #9

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
hi Axel,

I expect theirs to be online in the next few days.
Maarten Engels
Visual Productions BV

 

SMF spam blocked by CleanTalk