Visual Productions forum

Author Topic: Ubuntu 64-bit  (Read 2034 times)

September 01, 2011, 10:17:00 AM
Read 2034 times

Zolcsi

  • Member
  • *
  • Posts: 1
Hello,

I have downloaded the Ubuntu version of Cuelux but couldn't install because I have 64-bit Ubuntu and only the 32-bit version is available on your website.

Is there a 64-bit version?
Or is it planned for the future?
Or is there any way to install the 32-bit deb file on the 64-bit Ubuntu?

I tried sudo dpkg -i --force-architecture ./cuelux10328.deb but it failed with some missing depedencies.
Then I tried to install all depedencies (sudo apt-get install libc6-i686 libmikmod2 libsdl-mixer1.2 libsdl-net1.2 libsmpeg0 libboost-system1.42.0 libboost-regex1.42.0 libboost-filesystem1.42.0) but it failed because some of these packages are unavailable on the 64-bit Ubuntu.

Please help. Thanks a lot!

September 01, 2011, 03:52:52 PM
Reply #1

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
hi Zolcsi,

You right, at the moment Cuelux is only available for 32-bit Ubuntu.

I would like to support 64-bit Ubuntu as well in the future, but it is unlikely that we will prioritise it in the next 12 months.

best regards,
Maarten
Maarten Engels
Visual Productions BV

June 14, 2017, 11:21:30 AM
Reply #2

DragonCreationS

  • Member
  • *
  • Posts: 1
Hi

I set up a computer with ubuntu 16.04 yesterday. I wanted to install the latest cuelux version on it, but the installer of ubuntu doesn't seem to do anything.

Is there a walkthrough how to install cuelux on ubuntu?

Thanks a lot!

Best regards, Markus

June 14, 2017, 01:52:32 PM
Reply #3

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
hi Markus,

At the moment Cuelux is designed for Ubuntu 14.04 and might not install on 16.04.
Later on this year we will upgrade the software to 16.04.

best regards,
Maarten Engels
Visual Productions BV

September 20, 2018, 08:03:59 PM
Reply #4

Klaus

  • Member
  • *
  • Posts: 162
Do you have a Cuelux version that installs on Ubuntu 16.4 32bit ?
I tried the latest 64 bit and older i386 on Ubuntu 16.04...
Klaus

September 21, 2018, 09:07:09 AM
Reply #5

Michael Chiou

  • Visual Productions
  • Member
  • **
  • Posts: 350
Hello @Klaus,

No unfortunately, we do not have a 32bit version for 16.04. From the next release, Cuelux is moving to Ubuntu 18.04 which doesn't have a 32bit version. Older versions like 1.3.96 might work on 16.04 or 14.04, so I would recommend trying that, but as I mention 32bit versions are no longer supported so it wont be receiving any new updates.

 Link to older versions: ftp://haarlem.visualproductions.nl/releases/museum/

Greetings,
Michael.
Michael Chiou
Visual Productions BV

September 21, 2018, 09:14:12 AM
Reply #6

Klaus

  • Member
  • *
  • Posts: 162
Michael
in my previous post I said I tried older i386 version
Please tell me which version exactly works on Ubuntu 16.04 -  32 bit
Thanks
Klaus

September 21, 2018, 11:52:28 AM
Reply #7

Michael Chiou

  • Visual Productions
  • Member
  • **
  • Posts: 350
Hello @Klaus,

I have just tested to see which version would work with Ubuntu 16.04, 32 bit and Cuelux 1.3.96 does work fine. So I would recommend you try to install that one.

Greetings,
Michael.
Michael Chiou
Visual Productions BV

September 21, 2018, 11:21:39 PM
Reply #8

Klaus

  • Member
  • *
  • Posts: 162
...Where is Cuelux 1.3.96 ( couldn't find it on ...harlem...museum
BTWCuelux 1.3.95 wouldn't install
and I found
https://www.howtogeek.com/252981/how-to-install-deb-packages-without-ubuntu-software-in-ubuntu-16.04/
How did you install ?
(I have a dual boot ( OSX / Ubuntu 16.04.1 )
Thanks
Klaus

September 24, 2018, 09:29:04 AM
Reply #9

Zoë Castle

  • Member
  • *
  • Posts: 288
    • http://www.visualproductions.nl
Hi Klaus

Cuelux 1.3.96 for Ubuntu 16.04 32 bit is in the museum folder: cuelux10396-i386.deb

My colleague Michael had it working last week.  There are some manual steps you have to include when installing as it is not just a "double click".

To give you an indication you will need to use the terminal and manually install the older libraries that are needed to support Cuelux. These libraries would have been installed by default with Ubuntu 2 or 3 years ago but now are updated so when you try to instal Cuelux you will see an error message with a list of all the missing or outdated library's that you will then need to instal from the internet.

Good luck!

Greetings Zoë

Zoë Castle
Sales Manager
Visual Productions BV

 

SMF spam blocked by CleanTalk