Visual Productions forum

Author Topic: Cuelux v1.03.29 beta  (Read 8305 times)

December 01, 2011, 04:38:53 PM
Read 8305 times

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
Dear All,

I have just finished a new Cuelux release, v1.03.29. For this release I focused primarily on fixing bugs that have been reported over the last few months. Some issues still remain, they will be addressed in the next release together with some features that have been requested.

For those who would like to help me test this new release, it is available from our FTP server at ftp://haarlem.visualproductions.nl. Please let me know if you run into any issues.
After this testing period, I will put the release on the website's download page.

These are the release notes:

/****************************************************************************************
 *   RELEASE 1.03 Build 29
 ****************************************************************************************/
Release Date  : 2011 December 1
New Features  : - White Colour channel is dimmed together with RGB.
                - Czech language file
                - Slovak language file
                - Danish language file
                - Korg nanoKontrol 2 midimap
                - Alias names are now used when patching a fixture
                - Multi colour slots on a colour wheel are now also drawn correctly when
                  the number of colours >2.
                - Pan/Tilt Speed control in Position page in programmer.
                - Fixture view now also shows percentage in level bars.
                - Return from menus (Patch, Group, etc) by pressing the ESC key
Solved Bugs   : - Select some fixtures and sub-fixtures, then change 'virtual dimmer'
                  property in patch menu. This would lead to a crash.
                - Select some fixtures and sub-fixtures, then record on a playback fader
                  in order to create a group. Only the fixtures would be stored now.
                - Spanish language file was missing because of XML syntax error.
                - The red decimal address information was missing in the iPhone remote.
                - A macro channel ignore the 'reserverd' range at startup.
                - In colour picker window, clicking OK without having selected a colour
                  caused a crash.
                - FINE button in Programmer page 'Position' did not work correctly
                - Cosmetic fix in Fanning dialog (in Programmer page 'Position')
                - making a fixture selection by dragging the mouse on the 25-48 page
                  failed.
                - Inapproprate Virtual Dimmer on sub-fixtures that belong to a main-
                  fixture with a dimmer channel.
                - Using the Pan/Tilt control in the 'Position' Programmer page could
                  crash on Windows XP.
                - In the Cuelist Generator wizard, the 'next' and 'finish' button were
                  sometimes enabled when they should not have been.
                - Mac OS X Lion full screen bug repaired
Limitations   :   -

Best regards,
Maarten
Maarten Engels
Visual Productions BV

December 03, 2011, 03:11:37 AM
Reply #1

Michaelmoore83

  • Member
  • *
  • Posts: 164
    • Intense Sound & Lighting LLC
How does Pan / Tilt speed control work? It seams disabled for all of the fixtures I usually use.
Emulation 1.3.36 on Mac OS X 10.8.2
Controllers: Livid OHM RGB, "new iPad", Korg Nanokontol

December 03, 2011, 11:33:05 AM
Reply #2

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
Until now we had dedicated fader for Pan/Tilt speed. Usually it is assigned to one of the custom faders. Now we have a special fader for it, we need gradually change the personality file to use this fader in stead.
Maarten Engels
Visual Productions BV

December 07, 2011, 08:45:38 AM
Reply #3

Julien Levaufre

  • Global Moderator
  • Member
  • *****
  • Posts: 2360
    • www.visualproductions.nl
Youhou ;D a new release of cuelux! And a big party next friday! I'm sure i will enjoy it! :o
Julien Levaufre
Visual Productions BV

December 08, 2011, 09:14:03 PM
Reply #4

AxelF

  • Member
  • *
  • Posts: 152
Maarten,

the selection of fixtures works not well but it works.

The deselection selects more than it deselects.

This was tested on a touchscreen. If you try it with the mouse, it works well.

Unfortunately my reported bug regarding dimmed cues is still present.

Regards

Axel

December 13, 2011, 09:57:37 AM
Reply #5

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
It's online now
Maarten Engels
Visual Productions BV

December 13, 2011, 02:10:44 PM
Reply #6

AxelF

  • Member
  • *
  • Posts: 152
Maarten,

what is online ? Where ?

The 1.03.29 beta, where the touchscreen doesn't work at all ?

Regards

Axel

December 13, 2011, 02:16:44 PM
Reply #7

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
hi Axel,

You can download it from the usual place at  http://www.visualproductions.nl/downloads.html

Software doesn't notice the difference between a touchscreen-click or a mouse-click. A touchscreen driver turn the touch into a mouse-click, which the software will respond to. If you say the mouse works, then the software is ok. It's worth checking your touchscreen settings.

cheers,
Maarten
Maarten Engels
Visual Productions BV

December 13, 2011, 02:29:33 PM
Reply #8

AxelF

  • Member
  • *
  • Posts: 152
Maarten,

I have tested it before I wanted to bother you:

The behaviour is exactly the same: On one press of the touchscreen some fixtures are selected together. At the next press some are deselected some other selected.

The touchscreen works fine with other applications like Phoenix4 and worked well in 1.03.28. If you want I can try to help you to fix that, otherwise I can use the 1.03.28 again, because the 1.03.29 doesn't have any advantage for me.

Regards
Axel

December 14, 2011, 03:03:43 PM
Reply #9

Monkey

  • Member
  • *
  • Posts: 164
when will appear the 1.03.29 for Emulation?

why is there no Fader on the speed channel.
(Martin Mac250+ mode 4)

« Last Edit: December 14, 2011, 03:12:11 PM by Monkey »

December 15, 2011, 11:16:39 PM
Reply #10

Cornelis

  • Member
  • *
  • Posts: 32
Hello Maarten,

I tested some functions in the new version... (RELEASE 1.03 Build 29)

 - Return from menus (Patch, Group, etc) by pressing the ESC key

Patch, stack, cue, and play work, but group doesn't...

Regards,

Cornelis

December 16, 2011, 05:21:22 PM
Reply #11

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
@ Monkey
We used to assign the Pan/Tilt speed channel to a custom fader. Now we have a dedicated fader for this. We will bit-by-bit change all the personality file to use this new fader, in the mean time please use the custom fader when available.

@ Cornelis
Thanks for letting me know. I have put it on my todo list now.
Maarten Engels
Visual Productions BV

December 23, 2011, 09:14:40 AM
Reply #12

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
Maarten Engels
Visual Productions BV

December 23, 2011, 09:17:29 AM
Reply #13

AxelF

  • Member
  • *
  • Posts: 152
Maarten,

yes, it seems to be the same problem.

Please notice, that the previous version 1.03.28 didn't have that problem.

Regards
Axel

December 25, 2011, 11:06:34 AM
Reply #14

DJob

  • Member
  • *
  • Posts: 32
    • stage-support.com
I have a strange problem with cuelux 1.03.29 on on my macbook with snow leopard: 10.6.8. When I minimize cuelux and maximize again, the screen gets all blue. I have a picture added...


And yesterday when I wanted a cuelist to stop, I pressed and hold the "play button" above the fader and after the usualy time the light in the button turned orange and it said REL in the cuelistlabel, and kept going... I had to unasign the fader and reasign it again in the play window. I don't have a picture of this...

And sometimes if you move a fader quite quickly on the behringer bcf-2000 the faderstart does't work.

« Last Edit: December 25, 2011, 11:13:17 AM by DJob »

 

SMF spam blocked by CleanTalk