Visual Productions forum

Author Topic: Hardware controller  (Read 6571 times)

April 16, 2013, 02:54:55 PM
Reply #15

bourby

  • Member
  • *
  • Posts: 212
Well .. it would be ace if you did ..


April 17, 2013, 08:16:32 PM
Reply #16

Boyd Nijsten

  • Member
  • *
  • Posts: 202
    • www,guusvandenakker.nl
Is there a new Midi Api, i noviced the commands are changed...

April 18, 2013, 09:42:34 AM
Reply #17

Dennis Kromhout

  • Member
  • *
  • Posts: 838
Yes, there are some changes to the midimap but at this time the documentation hasn't been updated yet.

Most important change is the trigger type and the new field "identifier".
Old:
Code: [Select]
<action>
<trigger type="Midi" specifier="Change">Channel X - Message 9 - Index 53</trigger>
<tasks>
<task type="Playback Button 1" feature="ButtonSecundair" function ="Control"/>
</tasks>
</action>
<action>
<trigger type="Midi" specifier="Change">Channel X - Message 9 - Index 54</trigger>
<tasks>
<task type="Playback Button 2" feature="ButtonSecundair" function ="Control"/>
</tasks>
</action>

New:
Code: [Select]
<action>
<trigger type="Message" specifier="Change">Channel X - Message 9 - Index 53</trigger>
<tasks>
<task type="Dashboard Playback Button" identifier="0" feature="ButtonSecundair" function ="Control"/>
</tasks>
</action>
<action>
<trigger type="Message" specifier="Change">Channel X - Message 9 - Index 54</trigger>
<tasks>
<task type="Dashboard Playback Button" identifier="1" feature="ButtonSecundair" function ="Control"/>
</tasks>
</action>
Dennis Kromhout

April 29, 2013, 02:51:52 PM
Reply #18

bourby

  • Member
  • *
  • Posts: 212
I just got a Midicon ..

Is there no longer a Bump button on the Playback buttons?

The Midicon seems to have changed a bit, is there a mapping to show these changes?

May 01, 2013, 10:07:05 AM
Reply #19

bourby

  • Member
  • *
  • Posts: 212

May 01, 2013, 11:13:11 AM
Reply #20

ZoŽ Castle

  • Member
  • *
  • Posts: 288
    • http://www.visualproductions.nl
Hi Bourby

We have had a National Holiday this week as we now have a new King....

Dennis is back in work later today so I am sure he will look at your post, I dont know the details to answer you on this one.

Sorry for the delay but a new Dutch King, I hope, is a good excuse for not answering you straight away :-)

Have a good day, greetings Zoe
ZoŽ Castle
Sales Manager
Visual Productions BV

May 01, 2013, 12:25:55 PM
Reply #21

bourby

  • Member
  • *
  • Posts: 212
Well congrats .. being and Aussie, I don't really understand the significance ..

Marteen said there would be a software update today, will this be pushed back?

May 01, 2013, 12:55:55 PM
Reply #22

ZoŽ Castle

  • Member
  • *
  • Posts: 288
    • http://www.visualproductions.nl
Well congrats .. being and Aussie, I don't really understand the significance ..

"Being an Aussie" you have a very old Queen who I am sure will soon abdicate and then you too will get a day off work :-)

We are still aiming for a release today as stated...will try our best.

Greetings Zoe

ZoŽ Castle
Sales Manager
Visual Productions BV

May 02, 2013, 03:56:16 PM
Reply #23

bourby

  • Member
  • *
  • Posts: 212

May 02, 2013, 04:24:37 PM
Reply #24

Boyd Nijsten

  • Member
  • *
  • Posts: 202
    • www,guusvandenakker.nl
There is a new verison online, see ftp://haarlem.visualproductions.nl/releases/
Only MIDI input isn't working, but they are working on that?

May 03, 2013, 10:22:32 AM
Reply #25

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
@bourby

I just checked the 'flash' button in the playback-button area. It works fine. The thing to remember is that a flash-button for a playback-button is not always that usefull as the playback-buttons don't have a intensity-fader their intensity is fixed 100% so flashing would not gain anything. We mapped the flash button because it is usefull if you set the playback to 'fader start'.
Maarten Engels
Visual Productions BV

May 03, 2013, 12:55:24 PM
Reply #26

bourby

  • Member
  • *
  • Posts: 212
Still doesn't seem to work, and don't seen to have tempo.

How do I adjust the fade in time of a recorded playback button, can I stap it on? Or make it longer?

Can I get a current button map for the midicon please.

At a gig rig now .. Reply would be handy :)

May 03, 2013, 05:47:15 PM
Reply #27

Dennis Kromhout

  • Member
  • *
  • Posts: 838
Here is the midimap for the Midicon, this should fix the tempo tab issue.

Editing the cuelists fade time can be done using: "Memories" -> "Cuelists"
or
Press "Edit" Button and click on the playback. Now Select "Edit Cuelist"
Dennis Kromhout

May 03, 2013, 06:04:34 PM
Reply #28

bourby

  • Member
  • *
  • Posts: 212
So this midimap is different to the factory one?

Can we get a diag of the buttons? .. a few things seem to not be right.

May 06, 2013, 10:20:00 AM
Reply #29

Dennis Kromhout

  • Member
  • *
  • Posts: 838
The only difference with the file above and included in current beta is that the tempo tap now works.
The functions should be similar to how it works for Cuelux (non-pro).
For CueluxPro there's no documentation at the moment, when we have it we will post it on the forum.
Dennis Kromhout