Visual Productions forum

Author Topic: Firmware v1.03  (Read 2270 times)

July 03, 2015, 09:16:32 AM
Read 2270 times

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
Dear all,

We have made a new v1.03 firmware for the LPU-1 and LPU-2. We recommend you upgrade your device.
To upgrade please run vManager v1.3.92 which you can download from http://www.visualproductions.nl/downloads.html.

The release notes are:
Code: [Select]
LPU-1 v1.03     : - Set Art-Net destination IP via vManager
                  - Bug-fix for playing/stopping solo playbacks
                  - At startup; the LPU does not show up with ip 0.0.0.0 in the app/vManager
                  - Supports parked channels in personality files
                  - Universe 0 is not send out anymore for sACN
                  - Fx's with high speed run now smoothly
                  - For the Random Intensity FX, the phase fader now controls the amount of 'on'
                  - The Full Twinkle FX is implemented
                  - Bug fix for focus channels
                  - Bug fix for encoder, which where broken (changing different playbacks) after
                    playback swapping
LPU-2 v1.03     : - Bug-fix for Art-Net output
                  - OSC, UDP & TCP feedback
                  - The cue-index in a Jump via OSC command was treated 0-based, now it
                    is 1-based.
                  - Set Art-Net destination IP via vManager
                  - Bug-fix for playing/stopping solo playbacks
                  - At startup; the LPU does not show up with ip 0.0.0.0 in the app/vManager
                  - Supports parked channels in personality files
                  - Web-interface; including a monitor page (output, UDP, TCP, OSC)
                  - Universe 0 is not send out anymore for sACN
                  - Fx's with high speed run now smoothly
                  - For the Random Intensity FX, the phase fader now controls the amount of 'on'
                  - The Full Twinkle FX is implemented
                  - Bug fix for focus channels
                  - Bug fix for encoder, which where broken (changing different playbacks) after
                    playback swapping

Because of a bug in the playback swapping, a situation could occur where faders/encoders are changing setting of a playback they don't belong to. This new firmware provides a fix for this problem, however, to fix this without breaking your current show requires some caution.
Before performing a firmware upgrade, save your show in a show file. Then perform the firmware upgrade and, using the vManager tool, restore the 'factory default' settings in your LPU device. Then restore the show by opening the show file you have created just before the upgrade.
Now all should work as expected.
« Last Edit: July 03, 2015, 09:18:18 AM by Maarten Engels »
Maarten Engels
Visual Productions BV

July 03, 2015, 09:40:29 PM
Reply #1

Frankyferengi

  • Member
  • *
  • Posts: 93
    • DJ FRANK.EE
too bad, the error with the regulation about the pots, on other cue fields, is not fixed with the new firmware.
Cuelux v.1.3.94 VAIO Notebook, 2.4Ghz Core2Duo,
4GB RAM, Win7 64bit Home. MIDIcon , TouchOSC, iPad Air

July 06, 2015, 10:13:55 AM
Reply #2

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
hi Frank,

Just to check; did you use vManager to make a 'factory default' reset before trying?
Maarten Engels
Visual Productions BV

July 06, 2015, 12:09:16 PM
Reply #3

Frankyferengi

  • Member
  • *
  • Posts: 93
    • DJ FRANK.EE
Yes i dit, and The new Firmware is displayed.
Cuelux v.1.3.94 VAIO Notebook, 2.4Ghz Core2Duo,
4GB RAM, Win7 64bit Home. MIDIcon , TouchOSC, iPad Air

July 06, 2015, 02:37:15 PM
Reply #4

Maarten Engels

  • Administrator
  • Member
  • *****
  • Posts: 2383
    • www.visualproductions.nl
Ok, we will investigate it further.
Maarten Engels
Visual Productions BV

July 06, 2015, 11:10:57 PM
Reply #5

AxelF

  • Member
  • *
  • Posts: 152
Some things seem to work better now, but I don't know if the firmware update to 1.03 or the IPad Cuety update to 1.02 is responsible.

Anyway there is still a lot to do....


 

SMF spam blocked by CleanTalk