Visual Productions forum

Author Topic: UDP adds "00" (HEX) at end of every UDP command  (Read 784 times)

December 05, 2016, 12:19:56 PM
Read 784 times

hwavt

  • Member
  • *
  • Posts: 1
Every UDP command the B station or IOcore sends out gets an aditional "00" (in HEX) at the end of the command. With regular UDP devices this is not a problem. But trying to communicatie with an Eclere Duo-net player, wil reboot the Duo-net player.

I would like to know why the "00" is added and if it's possible to avoid the "00".

Kind regards,
Hans

December 05, 2016, 02:14:31 PM
Reply #1

Guido Visser

  • Administrator
  • Member
  • *****
  • Posts: 227
    • Visual Productions
Hello hwavt,

We had originally implemented all UDP messages as C style strings. Which end with a null character.
At this point the IoCore and B-Station send all UDP message this way.

However UDP also has a field which is used to specify the length of the data.
Therefore the null character is not needed.

At this moment there is no option available to remove the null character.
We will change this in the next firmware update.

Best regards,
Guido
Guido Visser
Visual Productions BV

 

SMF spam blocked by CleanTalk