Visual Productions forum

Author Topic: Unexpected Behaviour in OSC  (Read 447 times)

November 11, 2017, 03:44:59 PM
Read 447 times

c2b

  • Member
  • *
  • Posts: 9
Hi!

I have recently stumbled into a small issue with Cuecore, hoping you could advice.

I am using OSC to trigger audio playback (Vezer)
The OSC message (float <1.0>) is triggered correctly but the value is always 0 instead of the 1 i am after (see image)


EDIT: As far as I can investigate this seems to be a problem with the length in my OSC message?

Further:

Once I upload information through "Restore" function it seems to be unresponsive.
I need to manually go through the OSC messages and force a refresh to see messages coming out


(Probably) Important info:
The behaviour seems to be the same both with int and float types (see images)
I am generating my own XML files that I restore into cue core. There is no difference in syntax from mine to the ones made by the web app
I have tried this across several OSC packages (Touchdesigner, OSCTestApp), machines and cue cores.
I have tried with clean showfiles both generated by me and by the web app
Cue core is PCB version 2.4 running 1.22 firmware
« Last Edit: November 11, 2017, 04:13:37 PM by cvale »

November 13, 2017, 02:50:00 PM
Reply #1

Guido Visser

  • Administrator
  • Member
  • *****
  • Posts: 227
    • Visual Productions
Hello Cvale,

You are right there is a problem with the OSC messages when using a long URI. This is a known problem. And we have resolved the problem in the next update. (not available as of writing)

As you have noticed this is a problem with the length of the URI. If you can use a shorter URI there should not be a problem.

We are currently planning when we will release the version with the solution. Can you tell me when you need it. Then we can try to take this into consideration for the planning.

Until it is release you will have to use a shorter URI.

Best regards,
Guido
Guido Visser
Visual Productions BV

November 13, 2017, 03:08:17 PM
Reply #2

c2b

  • Member
  • *
  • Posts: 9
Hi Guido,

We start installing tomorrow so I will work around for now.

Next time ;)

 

SMF spam blocked by CleanTalk