Visual Productions forum

Author Topic: Cuelux crash at startup on Mac OS X 10.14  (Read 837 times)

December 24, 2018, 02:13:55 PM
Read 837 times

svens

  • Member
  • *
  • Posts: 9
Hello,

today I upgraded my Mac to OS X 10.14. After the upgrade, Cuelux crashes on every start (I can see the UI for some seconds and then it just closes and gives me the system error report). I then deleted all the files in the Visual Productions folder in my User Account and I could start Cuelux correctly.

Then I tried to move the files back into the Visual Productions folder and it turns out that the problem is related to my Midimaps. I am using three different Midimaps (based on the Korg nanos, sometimes I use only one and sometimes I use up to three ones) but I just can not figure out the problem. Can you tell me what I have to change in the Midimaps (see attached) so that they work properly with Cuelux again?


Kind regards

Sven

January 02, 2019, 12:30:03 PM
Reply #1

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 478
Hi,

I got it working by shortening the filenames ( I used np.xml, np2.xml, nk.xml )
Does this work for you as well?

Greetings,
Bootsy

January 02, 2019, 05:21:43 PM
Reply #2

svens

  • Member
  • *
  • Posts: 9
Hi Bootsy,

no, unfortunately this does not work for me. It still crashes at startup. I attached the crashlog, maybe this helps you.


Regards

Sven

January 02, 2019, 05:59:02 PM
Reply #3

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 478
Hi,

Apparently it only works for me when I copy in a factory midi map file as well (I used the behringer file)

I've marked this as a bug.

Perhaps you can try the exact same files I have, and see if it works for now.
I'll include them in the message.

Greetings,
Bootsy

January 02, 2019, 09:35:28 PM
Reply #4

svens

  • Member
  • *
  • Posts: 9
Hi Bootsy,

yes, for me its also working with another midi map in the same directory - also with the original names. This solution seems to be okay for now, but I have not tested if it runs stable for a longer session.

Thank you for this quick solution!


Regards

Sven

 

SMF spam blocked by CleanTalk