Visual Productions forum

Author Topic: Communication problem between lpu-2 and kiosc  (Read 294 times)

August 12, 2020, 03:41:34 PM
Read 294 times

Omernissim87

  • Member
  • *
  • Posts: 4
I have a problem...
I can see the device in the cuety remote but i canít see it on the kiosc🤔
What i am missing here???

Thank you

August 12, 2020, 04:55:41 PM
Reply #1

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 348
Hi,

To control the LPU-2 with Kiosc, you will have to make a layout using Kiosc Editor. For this, you will need the API commands for the LPU-2. These are all in the manual, starting from page 43. (Appendix A) You can find the manuals here.
I recommend using OSC.

To control a button in Cuety, you can simply drag in the button in Kiosc Editor. You will have to enter the right OSC tag:
/pb01/bu

The button's behaviour needs to be set to type Bool. This will control playback button 1. for others, simply change the "01" part to a different number between 01 and 64.

For a fader to control intensity, drag in a fader and give it the OSC tag:
/pb01/in

The fader's behaviour should be set to type Float. The min/max value should be 0 and 1. This should be the default values for the fader in Kiosc Editor anyway.

Now you will have to connect Kiosc to Kiosc Editor. Make sure you have both devices connected to the same network. (Using Kiosc Editor and Kiosc on the same Windows PC will not work unfortunately, this is because of limitations of the Microsoft Store...)
In Kiosc, in Remote, you should be able to select the Kiosc Editor running on the IP of your computer. Before you close the menu, there is one more thing you need to do. You will have to enter the OSC target in Kiosc. Open the OSC menu on the left, and add a target. The IP should be either the IP of your LPU-2, or a broadcast IP. Make sure you add the port after the IP address. It will look something like one of these:
192.168.1.10:8000 (Normal default IP of the LPU-2)
255.255.255.255:8000 (Broadcast IP)

The port for OSC is always 8000 on the LPU-2. (For UDP and TCP it is 7000) Close the menu and test your setup!

Once you have everything as you want it, you can save the showfile to your device running Kiosc. Simply switch from Remote to File mode in the menu, press File and press the save icon. Now if you select the showfile that appeared, the show is loaded on your device and is ready for use.

If you have any further questions, please feel free to ask!

Greetings,
Bootsy


August 12, 2020, 06:17:51 PM
Reply #2

Omernissim87

  • Member
  • *
  • Posts: 4
can you send me the link of these manual i cant find it

thank you

August 12, 2020, 06:30:12 PM
Reply #3

Omernissim87

  • Member
  • *
  • Posts: 4

August 12, 2020, 08:05:21 PM
Reply #4

Omernissim87

  • Member
  • *
  • Posts: 4
i figure it out with the kiosc editor but i still have the problem to connect the lpu-2 to the kiosc....i did what you write me before,but still i cant see the device in the kiosc...i see it only in the cuety.
i am missing here something,
you have a solution for me :-\

thank you very much
 ;D

August 13, 2020, 09:38:02 AM
Reply #5

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 348
Hi,

The LPU-2 never shows in Kiosc. You set an OSC target in Kiosc, using the IP of the LPU-2. This way you communicate with the LPU-2. So no need to select it as a remote or something.

You can browse to the IP of the LPU-2 in your web browser, there is a Monitor page there. If you open that, you can select OSC. Now when you press a button on Kiosc, the message should show up there. If it doesn't, you will have to check all network settings, and the OSC target in Kiosc.

If you still need help after this, please post the IP addresses of your devices here so I can check they are all in the same range.

Greetings,
Bootsy

 

SMF spam blocked by CleanTalk