Visual Productions forum

Author Topic: Midimaps for showcontrol  (Read 216 times)

December 05, 2021, 04:53:36 PM
Read 216 times

vincpiafff

  • Member
  • *
  • Posts: 4
Hi

I explore showcontrol to trigger playback Go of a cuelist with external midi signal from Reaper by virtual Midi cable (LoopMidi).
It seems that i can't reach any midi signal from my LoopMidi, while where i'm monitoring on MidiOX, Midi note are well received on the virtual midi channel... (Cf attachement)
I would like to simply triggers Playback 1 with Go action.
I tried by using generic map in Cuelux, without sucess ...

Thanks in adavance :)

Vince

December 05, 2021, 05:24:57 PM
Reply #1

vincpiafff

  • Member
  • *
  • Posts: 4
Here the screenshot from my midi note sended on "ChataigneToCuelux" virtual midi port

https://prnt.sc/21vcjad

December 06, 2021, 06:54:18 AM
Reply #2

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 500
Hi Vince,

I think the easiest to check first is to download CueluxPro. It has a monitor page for midi (that can be used without license) and should show you the exact messages that you receive from Reaper/LoopMidi.

Based on your screenshots, my guess is that you have to change the channel to 2,3 or 4, the note to B and the octave t0 9.

Greetings,
Bootsy

December 07, 2021, 11:42:31 PM
Reply #3

vincpiafff

  • Member
  • *
  • Posts: 4
Hi Bootsy

Thanks for your time.

I tried with cueluxPro, in attachement what i get with CC.
Trigger active well my cuelist in Pro but nothing happen in basic Cuelux...

Is there anything i mess? ... Everything is in attachements

Cheers!

Vince

December 08, 2021, 09:07:32 AM
Reply #4

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 500
Hi Vince,

It all looks good, not sure why it is not working... But perhaps you can try this instead:
Code: [Select]
<action label="Action 04">
    <trigger type="Midi" specifier="Down">Channel 0 - Message 9 - Index 3</trigger>
        <tasks>
            <task type="Playback Direct Button 03" feature="Play State" function ="Set">
            <argument type="Play State">Go</argument>
            </task>
        </tasks>
    </action>

It isn't actually documented, but I found that command while digging through the code a while back.

I will also attach the Cuelux midi documentation to this post.

Let me know what works and what doesn't, it might be a bug. Or perhaps this command needs a Note On instead of a Control Change...  If I have time I can test it at the end of the day, but currently I am very busy unfortunately.

Greeting,
Bootsy

December 12, 2021, 09:20:25 PM
Reply #5

vincpiafff

  • Member
  • *
  • Posts: 4
Ok

The Generic midimaps seems to be bugged ...
I tried with a AkaiMPC40 midimaps and it works :)

Thanks for your Help!

Vince

 

SMF spam blocked by CleanTalk