Visual Productions forum

Author Topic: Problem with APC Mini  (Read 1183 times)

February 09, 2022, 02:53:57 PM
Read 1183 times

WormRotterdam

  • Member
  • *
  • Posts: 2
My AKAI APC Mini controller is not working the way is supposed to  :o

I'm using the default midimap that cuelux provides.
What happens is that the fader curve is not completely correct from 1-127, There are some stops and glitches back to 0%,50%, etc
The biggest problem is that other midi channels start responding when using a single channel.

I've tested the controller on different pc's and the same happens with cuelux. Other software E.g. Ableton works just fine. :)
If someone has a fix for this, Or a custom midimap for the AKAI APC Mini that works with cuelux it would be greatly appreciated :)
In the video i'm simply adjusting the faders in chronological order from 0-100% I'm only touching one fader per time.

This video shows what happens:

https://youtu.be/puhLtWilcYA
https://streamable.com/zcf7z0

Any tips are greatly appreciated!


February 11, 2022, 06:51:56 AM
Reply #1

Julien Levaufre

  • Global Moderator
  • Member
  • *****
  • Posts: 2513
    • www.visualproductions.nl
I am using a AKAI apc mini for years and I faced the same issue than you.
But it appeared only when the controller was a few years old ( mainly one or 2) so I switched the controller to a new one and the problem was gone. I actually used 4 of them in 6 years. ( Luckily they are not that expensive).
So, my point of view is that the problem is coming from the controller...But you say that you don't have any issue when using it with ableton...  so it's strange! ???
But we can see in your video that when you are moving only one fader, Cuelux is actually receiving other informations than just this fader.
I don't which platform you are using but would it be possible for you to connect your midi controller to a midi tool like
midi-OX on windows to directly read datas from the akai apc midi? This way we will know if the problem is coming from the controller or the software.
http://www.midiox.com/moxdown.htm
https://www.youtube.com/watch?v=u8t9kAubeGQ
Julien Levaufre
Visual Productions BV

February 11, 2022, 08:36:51 PM
Reply #2

WormRotterdam

  • Member
  • *
  • Posts: 2
Hey! Thanks for your reply.

This is what is see in MidiOx when doing the exact same thing as i did in the last video, and pressing buttons after.
Besides the faders the buttons also seem to work as normal i assume?

see video with midiox:

https://streamable.com/8kq5yk
https://youtu.be/U0Q1atDEYTI






February 12, 2022, 06:33:04 AM
Reply #3

Julien Levaufre

  • Global Moderator
  • Member
  • *****
  • Posts: 2513
    • www.visualproductions.nl
I did the same test on my side with my akai mini APC, and it seems that the controller is working fine as data looks clean in midi-OX.
I will transmit this problem to the dev team to look for the bug and solve it as soon as possible.
sorry about this,

Julien Levaufre
Visual Productions BV

April 01, 2022, 11:59:07 PM
Reply #4

kent nielsen

  • Member
  • *
  • Posts: 6
good evening,
i just saw this thread.
i have the exact same issue, just with an elation midicon. Sometimes my system also change the play back page when moving a fader uo or down.
it seems like the problem is bigger if you move 2 faders at the time, or move them fast. 
i did try two different midicons.
running latest softvare version, downloaded about 3 weeks ago. on a win pc.
i will try sunday on a macbook pro.

« Last Edit: April 02, 2022, 12:01:08 AM by kent nielsen »

April 02, 2022, 12:47:37 PM
Reply #5

kent nielsen

  • Member
  • *
  • Posts: 6
now i did test with macbook pro. and from what i can se no issues there.
hope you find a solution soon. :-)

May 04, 2022, 10:57:47 AM
Reply #6

kent nielsen

  • Member
  • *
  • Posts: 6
good afternoon.
anything new in this issue?

May 04, 2022, 02:31:23 PM
Reply #7

Bootsy van der Zande

  • Administrator
  • Member
  • *****
  • Posts: 544
Hi,

I worked on this last week, and I found and fixed some issues. I had two midi devices (a Behringer and an Akai) to test with and it seems to be solved now.

Not sure when we will have an official release, but I might be able to make a new version next week so it can be tested. If you are interested to try and test this version, drop me an email on support at visualproductions.nl. Please include which operating system you use and make sure you back-up the visual productions folder. (Actually, always do that if you upgrade or downgrade!)

Greetings,
Bootsy

May 04, 2022, 03:10:40 PM
Reply #8

kent nielsen

  • Member
  • *
  • Posts: 6
great news.
i have sent you an email.

 

SMF spam blocked by CleanTalk